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ABSTRACT 

In this article possibilities, interface and basic work receptions in FORAN, are 

described, related to the construction of surfaces, on the surfaces constructionexam-

ple in the module Fdesign, menu GRA. FORAN is the powerful single system, wrap-

round all stages of designing and technological preparation, allowing rationally, in 

full and solely to conduct works on a project. FORAN is the flexible, module system, 

applicable to the ships of any type and by the shipbuilding factories of any size. 
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Постановка проблемы.Автоматическая система проектирования FORAN 

обладает широкими возможностями и предназначена для строительства судов. 

Система может быть использована как на этапе концептуального проекта, так и 

на последующих стадиях строительства и сдачи объекта [1].  

FORAN делится на следующие основные разделы: общее проектирование, 

проектирование и производство конструкции, проектирование и производство 

систем, чертежные работы, электротехника. 

FORAN является гибкой, модульной системой, применимой к судам любо-

го типа и судостроительными заводами любого размера. Модульный характер 

системы позволяет осуществлять ее внедрение поэтапно. Во всех своих приме-

нениях FORAN использует ту же модель конечного продукта и единый, удоб-

ный для пользователя интерфейс. FORAN является самой интегральной из всех 

ныне существующих систем.  

Связь работы с научными программами, планами и темами  

В статье приводятся результаты исследования, выполненного в рамках 

общего плана научных исследований Национального университета корабле-

строения имени адмирала Макарова и госбюджетной НИР № 1819 "Разработка 

методики определения параметрической надежности судна на начальных эта-

пах его проектирования". 
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Анализ последних исследований и публикаций 

При проектировании различных типов судов используются разнообразные 

системы автоматизированного проектирования. Широкое распространение в 

судостроительной отрасли получил программный продукт FORAN, который 

успешно внедряется в учебный процесс Национального университета корабле-

строения имени адмирала Макарова. Дисциплины, в которых используется 

FORAN: ″Проектирование специализированных судов″ и ″Проектирование об-

щего расположения судна″. 

Цель статьи – изучение возможностей, интерфейса и основных приемов 

работы в FORAN, связанных с построением поверхностей, на примере построе-

ния поверхностей в модуле FDesign, меню GRA. 

Изложение материала исследования и анализ полученных результатов 

FORAN – специализированная судостроительная система автоматизиро-

ванного проектирования, разработанная фирмой SENER для проектирования и 

строительства коммерческих и военно-морских судов. FORAN обеспечивает 

полный цикл проектирования для производства и включает в себя необходимые 

инженерные расчеты по корабельной архитектуре CAD/CAM [2]. 

При помощи современных 3D инструментов моделирования выполняется 

полное создание модели судна. Модель включает не только графическое пред-

ставление каждого компонента, но и в зависимости от вида детальную инфор-

мацию об изделии. Компоненты модели могут быть взаимосвязаны с другими 

компонентами. Изменение одного из связанных компонентов приведет к изме-

нению другого компонента в зависимости от свойств связи. Это позволяет бо-

лее эффективно модифицировать и дорабатывать существующую модель изде-

лия. Также легко осуществляется проверка на пересечение объектов модели. 

Интегрированная система FORAN обладает: общей и единой базой данных; 

одним и тем же языком и одними и теми же процедурами доступа для всех мо-

дулей; интенсивным применением топологического подхода в описании модели 

судна; отсутствием избыточности данных. 

Особенности FORAN – гибкость (максимум приспосабливаемости к нуж-

дам пользователя, предлагая предприятиям любой величины и организацион-

ной структуры настраиваемое решение для проектирования и производства лю-

бых типов судов); оптимально для моделирования и выпуска чертежей и доку-

ментации; простота использования; надежность; эффективность; коллективная 

работа; открытость (лёгкий обмен данными с техническими и информацион-

ными системами благодаря открытой структуре базы данных, архитектуре си-

стемы, использованию открытых стандартов и удобному интерфейсу); новатор-

ство. 

Система имеет модульную структуру, разделенную по специализациям[1, 

2]: 

– Hullformdefinition– возможность определения любой формы корпуса суд-

на, включая асимметричные суда и многокорпусные суда. Для создания по-

верхности используются методы построения поверхностей на основе NURBS-
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геометрии. Создание формы может производиться с нуля или на основе пред-

варительного определения.  

– Navalarchitecture– позволяет производить полные вычисления гидроста-

тических значений, кривых Бонжана, шкалу водоизмещений, кривые остойчи-

вости, свободный борт, допустимых длин отсеков, площади поперечного сече-

ния и схемы трюмов. Гидростатические вычисления могут быть произведены 

для различных осадок, углов крена и значения плотности воды. Специальный 

модуль системы позволяет оценить мореходные качества судна. 

– Hullstructure– быстрое, полное и точное определить 3D-модель корпус-

ных конструкций судна, включая листы наружной обшивки, палуб и переборок, 

листовые и профильные детали внутренних конструкций корпуса. Вся инфор-

мация о нормах, стандартах, параметрах конфигурации и других обязательных 

требований верфи централизована в базе данных.  

– Outfitting– проектирование оборудования, начиная с определения общей 

спецификации оборудования и элементов насыщения, норм трубопроводов, 

табличных свойств и ведомости материалов для каждой судовой системы.  

– ElectricalDesign– охватывает электрические аспекты при проектировании 

судна и производстве, позволяя пользователю объединять модели электриче-

ского оборудования с моделью судна (корпус, оборудование).  

– Accommodation– проектирование размещения помещений со всеми необ-

ходимыми компонентами (типы кают, стены, потолки, двери, окна, мебель и т. 

д.), полностью основываясь на модели судна. Инженер может работать в систе-

ме, используя 2D-черчение или 3D-моделирование. Оба эти способа взаимосвя-

заны. Результаты работы могут быть получены в виде чертежей и специфика-

ций.  

– BuildStrategy– различные инструменты для определения стратегии изго-

товления изделия. Используя 3D-модель судна, система позволяет определить 

этапы сборки, начиная с отдельных узлов, подсекций, и заканчивая последова-

тельностью сборки судна на стапеле. 

– Drafting– включает в себя полноценные инструменты для графического 

оформления чертежей.  

– ProductionLinks– получение необходимых данных для изготовления де-

талей производством.  

– ManagementLinks– обеспечение информацией нетехнических отделов 

верфи, которая необходима для планирования производства, закупки материа-

лов и учета их использования. 

– OtherInterfaces– интерфейсы передачи данных к другим системам в вы-

числительной инфраструктуре верфи и другим системам проектирования. Не-

которые форматы данных, поддерживаемых FORAN: 2D DXF, 3D DXF, IGES, 

STEP, VRML.  

– ExtensionsandUtilities– встроенный скриптовый язык программирования. 

Для управления базой данных в системе предусмотрены соответствующие ин-

струменты, обеспечивающие контроль, поддержание и восстановление базы 

данных. 
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Система поддерживается в операционных системах UNIX (Linux), Open-

VMS и WindowsNT. 

Модуль Fdesign основан на мощном параметрическом 3D-твёрдотельном 

моделере, который позволяет создавать твердые тела и поверхности, используя 

дружественный интерфейс. 

Основные особенности Fdesign: ″умные объекты″ (smartobjects) для фор-

мализации и распространения лучших методик проектирования; моделирование 

деталей из листового металла; управление большими сборками; анализ интер-

ференции и определение коллизий; совместимость твердотельного и поверх-

ностного моделирования; анимация и рендеринг. 

Fdesign работает с документами, типичными для Non-Manifold топологии, 

таким, как незавершенные объекты, объекты с внутренней поверхностью, раз-

деляющей разные материалы и объекты с многомерной геометрией (твёрдые 

тела, поверхности, кривые). Пользователь может создать деталь с взаимосвя-

занными размерами, каждый из которых может быть изменён в любое время и 

изменить размеры детали, выбрав какой-то размер и изменив его. 

Fdesign может быть использован как дополнительный инструмент в соче-

тании с Fsurf для импорта и модификации поверхностей из других форматов. 

Пользователь может импортировать, создавать и управлять сложными поверх-

ностями в Fdesign и экспортировать их затем в Fsurf. 

 Перейдем к рассмотрению построения простых моделей корпусов. А 

именно построение корпуса остроскулого катера. 

Исходными данными являются пространственные линии киля, скулы, ли-

ния борта. Так как мы рассматриваем именно построение поверхностей, то опу-

стим получение исходных линий. Данные линии мы импортируем с уже заранее 

заготовленного iges-файла.  

Таблица 1. Таблица плазовых ординат, мм 

Номер 

шпангоута 

Высота от ОЛ Полуширота Шпация 

Киль Скула Борт Палуба 

в ДП 

Борт Скула 

0 640 – 640 640 0 –  

1 50 274 620 662 586 352 900 

2 0 172 594 662 740 595 800 

3 0 130 580 – 750 682 700 

4 0 96 561 – 745 700 500 

5 0 74 552 – 735 700 600 

6 0 60 545 – 725 700 300 

Для построения взяты следующие исходные данные: теоретический чер-

теж моторной лодки с плоско-килеватыми обводами (рис. 1), таблица плазовых 

ординат. Данные представлены в таблице 1. 

В среде Rhinoceros получены линии киля, скулы и борта, далее импортиро-

ваны в FORAN. 
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Рис. 1. Теоретический чертеж моторной лодки с плоско-килеватыми обводами 

Используется команда Insert =>Surface =>Lofted =>Ruled. Указывается ли-

ния борта и скула (рис. 2). 

 
Рис. 2. Этапы построения поверхности моторной лодки в FORAN 

Аналогичное действие производится и для днища, указывается скула и ки-

левая линия. Далее соединяются две полученные плоскости командой Insert 

=>Surface =>Join (рис. 2). Для получения полного корпуса используется коман-

да Edit =>Mirror. Выделяются поверхности, которые необходимо отразить, в 

Symmetryplane указываются 3 points и выбираются три точки на килевой линии, 

также отмечается Copy, иначе просто отражается поверхность и не получается 

полный корпус.  

Для соединения целого корпуса используется команда Insert=>Surface 

=>Join. С помощью команды Insert=>Surface =>Plane, дорисовывается линия 
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соединяющая борт с диаметральной плоскостью (ДП), строится половина тран-

ца, далее отражается и соединяется с помощью Mirror и Join. Получается гото-

вая поверхность модели (рис. 2). 

Построение корпуса яхты по теоретическому чертежу (рис. 3). В данном 

случае исходные данные – графический файл, содержащий теоретический чер-

теж [3]. В среде Rhinocerosвосстановлены килевая линия, линия борта, наклон-

ный транец, а также несколько характерных шпангоутов.  

Для построения подобного типа корпуса лучше всего подходит команда 

Insert=>Surface =>Lofted=>Grid(рис. 4). 

Указываются линии одного направления (BoundarySetA) – здесь следует 

обратить внимание на то, что линия борта целая, а килевая линия разбита на два 

участка. Поэтомуносовой участок килевой линии выделяется, чтобы линии од-

ного направления не замыкали поверхность в острый угол, вторая часть линии 

указывается вместе со шпангоутами. 

 

Рис. 3. Теоретический чертеж яхты ″Таврия″ 
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Рис. 4. Этапы построения корпуса яхты по теоретическому чертежу в FORAN 

 

Рис. 5. Проверка качества построения поверхности в FORAN 
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Далее указываются все шпангоуты, начиная с отрезанной части килевой 

линии(BoundarySetB). Получается поверхность. Затем поверхность отражается с 

помощью командыEdit =>Mirror,и соединяются две поверхности Insert 

=>Surface =>Join. Транец добавляется с помощью команды Insert 

=>Surface=>Plane. Получается готовую поверхность (рис. 4). Качество постро-

енной поверхности проверяется в меню Tools =>Info.Для примера выбра-

наZebra(количество линий зебры задается), а также выполнена проверка кри-

визны по минимальному радиусу (рис. 5). 

Выводы и перспектива дальнейшей работы по данному направлению 

Система FORAN – интегрированная система, непрерывно развиваемая 

фирмой SENER, начиная с 1965 года. Сегодня, FORAN – мощная единая систе-

ма, охватывающая все стадии проектирования и технологической подготовки, 

позволяющая рационально, полно и едино вести работы по проекту. Применя-

ется для проектирования всех типов судов. Рассмотрение модуля 

Fdesignпрограмного продуктаFORAN оставило положительные впечатления. 

Реализовано много интересных идей и возможность глубокой настройки моду-

ля в целом, а также серьезные способы анализа построенных поверхностей.  
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